Как спрятать версию движка или апгрейдим wordpress

Уставшая собакаВообще-то сегодня планировалось написать восторженный пост на тему: «Вааау, я проапгрейдил движок с версии такой-то на версию такую-то».
Но знаете что?
Я не стал этого делать.
А знаете почему?
А потому что это — малость ненормально.

Вы ведь наверняка наблюдали такую картину на других блогах.
Вначале — блоггер напускает на себя шпиЁнский вид, и рассказывает вам (под большим секретом Полишинеля, конечно же) как спрятать от посторонних глаз версию движка, который вы в данный момент используете.
(Чтобы спрятать версию движка – надо просто поставить плагин WP-Replase version)

А через месяцок-другой – этот же блоггер пишет «восторженный пост», наподобие того, про который я сказал выше: «Проапгрейдился до версии такой-то, все нормально, установилась с полпинка» и т.д. и т.п.

То есть вначале – версию бложека старательно прячем, а потом – в том же бложеке сообщаем о ней всем желающим.

Это — немного смахивает на идиотизм, не находите?

К слову, версию можно спрятать, просто открыв «редактор тем» (конкретно – «шапку») и выдрав оттуда кусок кода, который отвечает за вывод версии.
Однако это — ни разу не решение, если вы используете генератор карт (Google XML Sitemaps).

Он — тоже выводит версию движка. Но она будет видна не вверху странички, а немножко пониже.

Особо одаренные граждане советуют не выдирать код, а прописывать на месте «wordpress» название другого движка.

Например, «Джумлу» (Joomla!).
Гражданам невдомек, что это бесполезно.

Любой, кто хоть мало-мальски знаком с движками вообще, и с вордпрессом — в частности, открыв исходный код морды вашего блога, сразу увидит там вот эти надписи: «all in one seo pack», «page navi», «see gallery shortcode in wp-includes/media.php», и т.д.

Большинство таких надписей – выводятся подключенными плагинами, и не надо быть семи пядей во лбу, чтобы вкурить, что подобные названия плагинов – имеет только wordpress, и никакой «джумлой» тут даже не пахнет.

В общем, давайте я просто расскажу вам, как сам обновляю все эти «вордпрессы».

К версии движка — привязываться не будем, потому как технология – идентична для всех версий.

Для начала – иду к Кактусу, и качаю нужную мне сборку.

Затем – начинаю эту сборку препарировать у себя на компе.
Загружаю в папку с плагинами нужные плагины (если их нет в сборке).
В папку с темами – закидываю тему, которая используется в данный момент.

Затем – правлю файл конфигурации, предварительно его переименовав.

(Для правки конфига – нельзя использовать «блокнот». Я использую «notepad2», лежит вот здесь http://www.flos-freeware.ch/ )

Потом – этот снаряженный по всем правилам движок пакую в архив и заливаю на хостинг.
Затем – захожу в админку блога, делаю бекап базы данных, а потом – вырубаю все плагины.

После этого – лезу в файловый менеджер на хостинге, и сношу из папки public html всё, за исключением трех вещей: папки с картинками для блога, архива с предыдущей версией движка, и архива со свежезалитой версией движка.

Затем – делаю распаковку архива с новой версией в папку public html.

Ну а потом – открываю «огнелиса» и в адресной строке набираю каноническое:

http://доменное_имя/wp-admin/upgrade.php

Если все сделано кошерно – движок заведется и скажет, что ему надо обновить базу данных.
Через несколько секунд — движок сообщит, что все нормально, и выдаст кнопочку с надписью «продолжить».

Нажимаю ее, и возникает окно со входом в админку.

Собственно, все.

Осталось только сказать о плагинах. После обновления — большинство плагинов окажутся активированными, как раньше.
Большинство, но не все.
Некоторые из них (наподобие вышеуказанного генератора карт) — придется колупать ручками и задавать им настройки по-новой.

А в остальном – никаких проблем. 🙂



Запись опубликована в рубрике Wordpress. Добавьте в закладки постоянную ссылку.